Apple Watch for Music Streaming To Lumity L90

Just want to share my experience with my Lumity L90 (With active vents) music listening from my Apple Watch (latest generation). As type this I am listening to my Tidal favorite tracks bluetooth streaming from the watch wifi connected to Tidal. It amazed me that sound quality was respectable with some music equalization settings in MyPhonak. I can walk around the house enjoying the Master tracks and do a double ear tap when my wife needs my attention (pauses the streaming and active vents open up). I can then tap on the watch to restart the track I was listening to. Volume is easily controlled with the watch side wheel. Side note: I have very high quality headphones and TWE earbuds for best listening quality but this setup is so convenient for listening on the move.

1 Like

Perhaps you have notifications from your phone set up differently. I’m using an iPhone and I find the iPhone continually steals “streaming authority” away from my Apple Watch when I’m carrying the iPhone around with me in a hip holster. I’m not streaming from the watch but when I exercise, I’d like to hear the mile lap announcements, etc., from the watch exercise app but if I am streaming from the iPhone, they don’t come through, which is annoying. Also, don’t know whether it has anything to do with the myPhonak program settings, but in trialing the Lumitys, Siri’s voice comes through pretty loudly from the watch. Even if I turn the volume down by rotating the watch crown, sometime later (haven’t kept track of whether it depends on a new day of unlocking the watch, etc.), an announcement from the watch will blast my ears.

I think things could work better from my point of view if Apple and Phonak could iron things out but I doubt that’s likely to happen. It’s strange, though, that Apple doesn’t make its watches work better with MFi HA’s. The connectivity between the watch and the Lumitys is great. Just wish one could give the watch more priority and that volume control settings “stuck.” Perhaps I need to adjust my “handoff” settings? Haven’t messed with those.